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Flow Designer Service Catalog Trigger not working unless a 'test' is run and a specific RITM record is selected - Support and Troubleshooting
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KB0778523

Flow Designer Service Catalog Trigger not working unless a 'test' is run and a specific RITM record is selected


6858 Views Last updated : May 15, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

The user is trying to convert their system from using workflows to using flow designer, but they are facing issues getting their flows to work for Service Catalog.

Cause

There is no method in the user's system to approve parent Request records. Without an approval being processed on the parent Request record, no approval gets passed down to the child RITM to kick off the Flow the user designed (per Business Rule "Cascade Request Approval to Request Item" on sc_request).

Resolution

Typically, the above-mentioned process is handled through the Out of Box (OOB) "Service Catalog Request" workflow which processes an automatic approval if the price of the ordered item is less than $1000.00.

The user can create their own Flow on the sc_request table, with their own parameters, to handle such an automatic process. This will ensure that the user's sc_req_item (RITM) Flows will kick off each time without issue.

For the user's convenience, attached to this Knowledge article is the OOB "Service Catalog Request" workflow so that they (or any user) can examine it and build their flow to model it, then customize it according to their needs.


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Attachments

Attachments

  • wf_workflow_version_b98a7cfd0a0a0b342c2de25a5bfe4588.xml

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