Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Setting a multi-row variable mandatory - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Setting a multi-row variable mandatory
KB0778516

Setting a multi-row variable mandatory


6857 Views Last updated : May 30, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

The user wants to know how to set a multi-row variable to mandatory. They are able to set the variables in the variable set mandatory, but that does not prevent the end-user from submitting the request with no data.

Cause

Note: Catalog UI Policies do not enforce mandatory behavior on Multi-Row Variable Sets (MRVS) in the non-portal (Platform UI) view. This behavior is only supported in the Service Portal. If MRVS fields must be mandatory in non-portal views, consider using a Catalog Client Script or other workarounds.

Resolution

Unfortunately, it is true that until or unless the user makes the multi-row variable set (MRVS) itself mandatory, an end-user can simply bypass the variable set even when the variables inside the MRVS are set to mandatory.

What is needed in this case is a way to force the end-user to open up the MRVS per the "Add" UI Action (prevent them from submitting the Request until they do this) - then, things will progress naturally (as at this point the user has already set the variables inside the MRVS to mandatory).

To do this, on the affected Catalog Item, create a Catalog UI Policy.

Within the Catalog UI Policy, create a Catalog UI Policy Action which sets the MRVS itself to mandatory. This change will now wholly prevent the user from ordering the Catalog Item until they interact with the MRVS. Then, when they open the MRVS per the "Add" button, the user has their mandatory variables and the end-user must provide values to proceed with submitting the Request.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.