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User is unable to login via LDAP - Support and Troubleshooting
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  • User is unable to login via LDAP
KB0778308

User is unable to login via LDAP


3910 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

User attempts to login with his/her LDAP credentials but gets the message "User name or password invalid".

Cause

When ServiceNow looks up the LDAP server with the Query field value (mail in this case) same as the UserID of the user, there are 2 users with the same value and hence the LDAP server returns the DN of the other user. 

This DN doesn't match the 'Source' field value of this user's sys_user record and hence the validation fails with the error:

2019-09-10 08:21:05 (503) Default-thread-10 9FB8F831DB733B4016E1FB541F961943 txid=36f8f471db73 WARNING *** WARNING *** LDAP: Validation failed for CN=Wrong User,OU=Users,DC=company,DC=org - AuthenticationException [LDAP: error code 49 - 80090308: LdapErr: DSID-0C090400, comment: AcceptSecurityContext error, data 52e, v1db1\x00] - using server LDAP-Server

Resolution

You need to make sure there no two users exist with the same value for the 'Query field' attribute (mail in this case). To fix the issue, you need remove this value from the incorrect user on the LDAP server. 

Once that's done, when ServiceNow looks up the LDAP server for a user with mail=<UserID of the user>, the LDAP server will find only 1 user and return the DN of the same. This will match the value in the 'Source' field in the user's sys_user record. 


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