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Description

ITIL role users cannot access Additional comments on Requested Item 'sc_req_item' form after upgrade to New York from previous releases.

Steps to Reproduce

This issue only reproducible after upgrading a previous release to New York.

  1. Apply an instance which is on Madrid release.
  2. Upgrade it to New York Patch 1 or EA via "Upgrade an instance" in HI Portal.
  3. Impersonate as the ITIL user.
  4. Open a 'sc_req_item' record.

Expected behavior: ITIL user should have access to Additional comments on 'sc_req_item' form.

Actual behavior: ITIL user doesn't have access to Additional comments on 'sc_req_item' form.

Cause:
A read ACL on 'sc_req_item.comments' is introduced after upgrade from Madrid to New York.
https://<instance-name>.service-now.com/nav_to.do?uri=sys_security_acl.do?sys_id=b6a48b9a8750330068ce0cf888cb0bae

Workaround

This problem is currently under review. You can contact ServiceNow Technical Support or subscribe to this Known Error article by clicking the Subscribe button at the top right of this form to be notified when more information will become available.

The workaround is to create a read ACL on 'sc_req_item.comments' and also provide the roles as ITIL.


Related Problem: PRB1360816

Seen In

New York Patch 1
SR - IRM - Advanced Risk - New York 2019 Q3
SR - IRM - Audit Management - New York 2019 Q3
SR - IRM - GRC Profiles - Madrid 2019 Q2
SR - IRM - GRC Workbench - New York 2019 Q3
SR - IRM - NIST CSF - New York 2019 Q3
SR - IRM - NIST RMF - New York 2019 Q3
SR - IRM - Policy and Compliance - Madrid 2019 Q2
SR - IRM - Risk Management - New York 2019 Q3
SR - IRM - SIG Assessment Legacy - Madrid 2019 Q1
SR - IRM - Vendor Risk Management - Madrid 2019 Q1
SR - ITOM - CMDB CI Class Models - 201908
SR - ITOM - Discovery and Service Mapping - 201908
SR - ITOM - Discovery and Service Mapping - v1.0.35

Intended Fix Version

Orlando

Fixed In

New York Patch 2

Safe Harbor Statement

This "Intended Fix Version" information is meant to outline ServiceNow's general product direction and should not be relied upon in making a purchasing decision. The information provided here is for information purposes only and may not be incorporated into any contract. It is not a commitment, promise, or legal obligation to deliver any material, code, or functionality. The development, release, and timing of any features or functionality described for our products remains at ServiceNow's sole discretion.

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2019-10-21 15:04:20
Published:2019-09-18