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Description

ITIL role users cannot access Additional comments on Requested Item 'sc_req_item' form after upgrade to New York from previous releases.

Steps to Reproduce

This issue only reproducible after upgrading a previous release to New York.

  1. Apply an instance which is on Madrid release.
  2. Upgrade it to New York Patch 1 or EA via "Upgrade an instance" in HI Portal.
  3. Impersonate as the ITIL user.
  4. Open a 'sc_req_item' record.

Expected behavior: ITIL user should have access to Additional comments on 'sc_req_item' form.

Actual behavior: ITIL user doesn't have access to Additional comments on 'sc_req_item' form.

Cause:
A read ACL on 'sc_req_item.comments' is introduced after upgrade from Madrid to New York.
https://<instance-name>.service-now.com/nav_to.do?uri=sys_security_acl.do?sys_id=b6a48b9a8750330068ce0cf888cb0bae

Workaround

please add an ACL on sc_req_item.comments having a 'read' role and also provide the roles as ITIL

 

 

Related community Article:

https://community.servicenow.com/community?id=community_blog&sys_id=3b2bf26a1b49c018d01143f6fe4bcb45

 


Related Problem: PRB1360816

Seen In

New York Patch 1
SR - IRM - Advanced Risk - New York 2019 Q3
SR - IRM - Audit Management - New York 2019 Q3
SR - IRM - GRC Profiles - Madrid 2019 Q2
SR - IRM - GRC Workbench - New York 2019 Q3
SR - IRM - NIST CSF - New York 2019 Q3
SR - IRM - NIST RMF - New York 2019 Q3
SR - IRM - Policy and Compliance - Madrid 2019 Q2
SR - IRM - Risk Management - New York 2019 Q3
SR - IRM - SIG Assessment Legacy - Madrid 2019 Q1
SR - IRM - Vendor Risk Management - Madrid 2019 Q1
SR - ITOM - CMDB CI Class Models - 201908
SR - ITOM - Discovery and Service Mapping - 201908
SR - ITOM - Discovery and Service Mapping - v1.0.35
SR - ITOM - Fundamentals Istanbul Jakarta Kingston r1 - v5.99.6
SR - Security - Integration Framework - Madrid 2019 Q2
SR - Security - Support Common - Madrid 2019 Q2
SR - Security - Support Orchestration - Madrid 2019 Q2
SR - SIR - Qradar SIEM Integration - Madrid 2019 Q1
SR - SIR - Security Incident Response - Madrid 2019 Q2
SR - SIR - Security Incident Response PA Content - New York 2019 Q3
SR - SIR - Store SecOps Setup Assistant - Madrid 2019 Q2
SR - SIR - Store Threat Core - Madrid 2019 Q2
SR - SIR - Store Trusted Security Circles Client - New York 2019 Q3
SR - SIR - Threat intelligence - New York 2019 Q3
SR - SIR - VirusTotal Integration - New York 2019 Q3
SR - VR - Vulnerability Response - New York 2019 Q3

Fixed In

New York Patch 2
Orlando

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2020-05-13 05:34:31
Published:2019-11-14