Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Issue with WMI/Powershell: Classify sensor - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Issue with WMI/Powershell: Classify sensor
KB0778183

Issue with WMI/Powershell: Classify sensor


1410 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

The Following Error is returned on (some) Windows Servers during a typical Discovery in the Discovery Log:

TypeError: Cannot read property "0" from undefined
Stack: at discovery_sensor.b11453f50a0a0ba500a72547a687189e:158 (anonymous)
at discovery_sensor.b11453f50a0a0ba500a72547a687189e:66 (anonymous)
at discovery_sensor.b11453f50a0a0ba500a72547a687189e:45 (anonymous)
at sys_script_include.778011130a0a0b2500c4595ad1d1d768.script:194 (anonymous)
at sys_script_include.778011130a0a0b2500c4595ad1d1d768.script:149 (anonymous)
at sys_script_include.778011130a0a0b2500c4595ad1d1d768.script:112 (anonymous)
at sys_script_include.778011130a0a0b2500c4595ad1d1d768.script:25 (anonymous)
at sys_script_include.d22e7bdbc0a8016500a18e024bfc9aa3.script:4 (anonymous)
at discovery_sensor.b11453f50a0a0ba500a72547a687189e:1
at sys_script_include.78dfb2dd536002001f175f43911c087d.script:13 (anonymous)
at sys_trigger.e09ce071db933300e822748e0f9619da:2
(sys_script_include.778011130a0a0b2500c4595ad1d1d768.script; line 56)


The Windows Server will fail to classify

Release

New York - patch 0(possibly others)

Cause

There are GPO (Group Policy Objects) in the customer's environment that can specifically cause this error. These are things that are somewhat out of our control, but there are some things that we can do to diagnose.

Resolution

  1. Compare the different CIs for the Windows Servers - see if any of them are not throwing this error and are being classified
  2. If there are servers that this is not happening to, then the most likely course of action is to compare the working Hosts to the Non Working Hosts. There is a command that you can run to print out the GPOs for each host and then you can compare them: gpresult/h report.html (returns an html file with the results).
  3. Eliminate any GPOs on the non working host that to not appear on the working host (remember that this would only apply to the GPOs that the Windows credential account for Service Now Discovery is tied to (ignore all other users from the report).
  4. (Optional) As a fallback you can always revert back to legacy WMI by setting the following property in ecc_agent_property.LIST: mid.use_legacy_wmi = "true"

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.