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Knowledge article 'Valid to' date changes when the knowledge base value changes. - Support and Troubleshooting
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  • Knowledge article 'Valid to' date changes when the knowledge base value changes.
KB0777724

Knowledge article 'Valid to' date changes when the knowledge base value changes.


7238 Views Last updated : Jul 24, 2025 public Copy Permalink English (Original)
  • English (Original)
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KB Summary by Now Assist

Issue

When the user changes the Knowledge Base associated with the article, the valid to date changes from the default value.

Release

New York and forward

Cause

  • New functionality added in New York release.
  • Default value for 'Valid to' field has been customized.

Resolution

In New York, there is a new field on the Knowledge base table called 'Article Validity'. This is used to set the default value for the 'Valid to' field for the base's articles. A default value of 1,080 days from article creation is used if a value is not set for the 'Article Validity' field. This is why the value is changing when creating a new article.

The Valid to field is updated by client script "Change Default Article Validity Date": /nav_to.do?uri=sys_script_client.do?sys_id=83be79e0cb2033007a94582df8076dff

Through this, the script include 'KBCommonSNC' is called: /nav_to.do?uri=sys_script_include.do?sys_id=39e84ab2d72121004792a1737e610306

Also, the default value for dictionary entry 'Valid to' has changed in New York:

javascript: current.kb_knowledge_base ? new global.KBCommon().getDefaultValidToDateFromCurrentDate(current.kb_knowledge_base) : '';

 

As the dictionary entry has been customized, the new default value in New York has not been added. Below are available options to resolve this behavior:

  • To use out of box functionality, set the default value in the 'Valid to' dictionary entry back to out of box. Then, the 'Article Validity' field can be utilized on the Knowledge base table.
  • Disable the client script "Change Default Article Validity Date" and use the existing default dictionary value. Please note, this is a customization and will fall outside of the scope of support.

Related Links

Knowledge Management release notes [New York]


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