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Workflow logs show error "Transaction cancelled: Available memory is almost depleted" - Support and Troubleshooting
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  • Workflow logs show error "Transaction cancelled: Available memory is almost depleted"
KB0761233

Workflow logs show error "Transaction cancelled: Available memory is almost depleted"


2080 Views Last updated : Sep 21, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Workflow logs are showing that the workflow context/workflow activities are being canceled due to an insufficient amount of system memory.

Release

All releases

Cause

Endless loop in workflow script.

Resolution

Check the workflow in question and ensure there are no loops such as for loops or while loops that never end. This can be taxing on an instance as the loop will continue running and eating up all the system memory until the instance crashes or cancels that job. Once the workflow activity job is canceled, eventually, the workflow activity will be picked up again by a node worker which will eat up all of the instance's memory again. In these cases, it is best to cancel the entire workflow, work on removing all endless loops, and then reattaching the new version of the workflow to the affected record.


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