Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Related list not showing columns values for non admin user - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Related list not showing columns values for non admin user
KB0761146

Related list not showing columns values for non admin user


2478 Views Last updated : Aug 24, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

On a form for non-admin users, the users are unable to see some column values on related lists.  The columns that do not show are dot walked fields.

Release

London, Madrid

Cause

This issue is related to ACL's and dot walking fields.   What can happen is that if an ACL has a script or conditions on specific fields.  If these fields are not defined in the related list, the ACL will not be able to properly evaluate because it does not have access to the field hence it will fail.

Resolution

Add the dependent fields that are using in the ACL to the related list and this should allow all the other dot walked fields to load.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.