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Users unable to publish knowledge articles - Support and Troubleshooting
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KB0761049

Users unable to publish knowledge articles


3017 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Users are unable to publish knowledge articles. They also cannot see the Publish UI action

 

Cause

The user does not pass the conditions on the Publish UI action

The user does not pass the conditions on the canPublish function from the script include KBKnowledge

1) The workflow state is draft
2) The user is the Owner of the Knowledge Base where the article resides or the user is an admin user
3) The user should be reviser or author of the article. Check the field revised_by and author
4) The user is a member of the Ownership group. Check the field ownership_group

Otherwise, by default, users cannot see the Publish button

Resolution

Review the Publish UI action conditions

Check if the user pass one of the above criteria to see the Publish button


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