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Resolved field is missing for indicator sources: Incidents.SLA.Resolved, Incidents.OLA.open and Incidents.SLA.Open - Known Error
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  • Resolved field is missing for indicator sources: Incidents.SLA.Resolved, Incidents.OLA.open and Incidents.SLA.Open
KB0760284

Resolved field is missing for indicator sources: Incidents.SLA.Resolved, Incidents.OLA.open and Incidents.SLA.Open


635 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

[PA Incident SLA] Daily Data Collection job is not completing successfully.

 

Release

This plugin is by default active in instances created after Fuji release but if instance was created before Fuji this plugin is inactive.

Cause

Reviewed the indicator sources for the collection job:  Incidents.SLA.Resolved, Incidents.OLA.open and Incidents.SLA.Open

The Resolved field shown in the OOB indicator sources are shown as a blank condition in the filter.

Resolution

The errors in the collection are due to the conditions present in the indicator sources Incidents.SLA.Resolved, Incidents.OLA.open and Incidents.SLA.Open
The additional conditions of these indicator sources are using a field from incident table 'resolved_at' which is currently not present in your instance and so while running the job you see these errors.

Therefore, the indicator sources in your instance for Incidents.SLA.Resolved , Incidents.SLA.Open and Incidents.OLA.Open has in the filter condition the resolved field which is blanked out.

The resolved_at and resolved_by fields on the incident table are available as part of a plugin 'Incident Resolution Fields' which is currently inactive in your instance.
If you activate this plugin these fields will be available in your incident table and so the collection errors would be resolved too.


Apply the "Incident Resolution fields" plugin to allow indicator sources to build properly.


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