Issue
- ServiceNow offers support for Kubernetes discovery and the procedure is explained in Kubernetes discovery document. However, even after following the steps, the Kubernetes resources cannot be discovered.
- The problem observed here is with Credential configuration. The expected outcome of command is as below.
![Locate the lines that contain information on password and username.]()
- However, on executing the command, the output we see is as below.
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- This article will demonstrate on the investigations and probable use cases, hence in future, if a similar error occurs then this can be one of the cause and worth trying to fix.
Cause
- This issue with the unsupported Kubernetes configuration.
Resolution
- ServiceNow Kubernetes Discovery supports credential configuration using Username and password as well as using bearer token. Thus to make it work, we need to have valid UserName details.
- In order to get the username and password details, we recommend using kubectl config view command to get the correct user details as per the screenshot in the document.
- If, in an environment, kubectl config view command is not showing the expected details then need to get the "supported" command from Kubernetes admin to fetch username and password details.
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