Issue
When the Connect Support Chat is transferred from one agent to another, the system messages like The support session was transferred to <Agent Name> or <Agent Name1> started a transfer to <Agent Name2> are not shown on the activity stream of record that is created from this support conversation.
Cause
This feature is controlled by the property glide.connect.support.reflect_system_messages.
Resolution
Setting this property to true will add all the system messages to the conversation.
Below is the link to the Property:
https://<instance_name>.service-now.com/sys_properties.do?sys_id=64768d009f112200d5f9b3e2957fcfd3