Issue
We had an email come out with the subject line of On-Call Schedule - Gaps and Conflicts on Monday. It went to quite a few of our employees, I am trying to find the report but can't see to find it to find out why it went to the number of employees it did.
Release
Madrid
Cause
Users with rota_admin role.
Resolution
The behavior seen is due to users with the rota_admin role. As the rota_admin role allows access to all Shifts (Rota schedules), all rota_admin users will receive the 'On-Call Schedule - Gaps and Conflicts' email.
If you subtract users who are not active/locked out/no email listed ect. this will explain why the number of users received the notification.
There is an out of box scheduled job that runs which sends the notification:
<Instance Name>.service-now.com/nav_to.do?uri=sysauto_script.do?sys_id=7eb56a4f73e82300cbb654eb7df6a76f
This calls the function sendReports in script include 'OnCallGapsConflictsReportSNC':
<Instance Name>.service-now.com/nav_to.do?uri=sys_script_include.do?sys_id=a913e4db731c2300cbb654eb7df6a7be
If you are wanting to implement different behavior, this function can be overridden in script include 'OnCallGapsConflictsReport':
<Instance Name>.service-now.com/nav_to.do?uri=sys_script_include.do?sys_id=62b94843538123004247ddeeff7b12be
You may also want to consider re-evaluating the users who have the rota_admin role in your instance to determine if they all require this role.
Related Links
Roles installed with on-call scheduling
https://docs.servicenow.com/csh?topicname=t_ActivateOnCallScheduling.html&version=latest