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Description

Export to pdf from the incident context menu is not available for itil users after upgrading to New York

 

Cause

<g2:evaluate var="jvar_context_menu_export_pdf" expression="gs.hasRightsTo('ui/context_menu.export_pdf/read', null) && ${ref}.canRead()" />

Resolution

The "Export to pdf" feature is coming from the UI macro"context_form_header"
https://yourInstance.service-now.com/nav_to.do?uri=sys_ui_macro.do?sys_id=2ff1c56ca9fe3dba014340c4697b5088
And to workaround this, comment out this part of the jelly code on line 19
<g2:evaluate var="jvar_context_menu_export_pdf" expression="gs.hasRightsTo('ui/context_menu.export_pdf/read', null) && ${ref}.canRead()" />

and add this new line to allow for example "itil" user role to have access to the "Export to pdf"
<g2:evaluate var="jvar_context_menu_export_pdf" expression="gs.hasRole('itil')" />


Article Information

Last Updated:2019-08-22 10:45:54
Published:2019-08-22