Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Pattern based discovery does not detect extra IP Addresses leading to concurrent discoveries and higher DB load - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Pattern based discovery does not detect extra IP Addresses leading to concurrent discoveries and higher DB load
KB0759072

Pattern based discovery does not detect extra IP Addresses leading to concurrent discoveries and higher DB load


2856 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

The DB CPU spikes or Read Replica lag occurs during active discovery schedule. Discovery scans on multiple IP Addresses of the same device went through full cycle leading leading to redundant DB operations. In theory, there should be only one IP Address scan went through the full Discovery cycle, the rest of the IP Addresses for the same device in a discovery schedule should be detected as extra/duplicated IP Addresses and halted. This behavior is observed during Probe based discovery. However, during Pattern based discovery, this did not happen.

Cause

Out of the box, Pattern based discovery do have features to detect extra/duplicated IP Addresses. The behavior is controlled by a couple of properties:

glide.discovery.ip_based.active = false
glide.discovery.device.duplicate.ip.optimization = true

 

However, an upgrade script checks to see if "Discovery - IP Based" plugin is enabled, if it is set the "glide.discovery.ip_based.active" to true. Probe-to-Pattern migrated instances will always have this property set to true. "glide.discovery.device.duplicate.ip.optimization" property is always true out of the box.

 

Because the property "glide.discovery.ip_based.active" is true for probe-to-pattern migrated instances, Discovery does not attempt extra/duplicate IP Address detection. This allows scans on all IP Address of the same device in the same discovery schedule to go through full cycle and needlessly runs redundant operations on DB leading to much higher DB load.

 

*** NOTE: The extra/duplicate IP Address detection feature make use of the "install_status" field on CI tables. This field is defaulted to 1 OOB. If the default value is removed or modified, this feature will not work.

Resolution

Set the following System Property:

glide.discovery.ip_based.active = false
glide.discovery.device.duplicate.ip.optimization = true

 

Make sure default value exists for at least IP Address or Network Adapter records.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.