Issue
The Trigger condition does not allow us to select the 'Contact' field as the value for 'User field.' It's visible, but grayed out.
Cause
Attribute set on User Field
Resolution
The behavior is seen due to the dictionary attribute 'reference_types' set on the User field in the trigger condition. Please see this attribute in the dictionary entry in the "Attributes" field:
Dictionary Entry - User field
<Instance name>/nav_to.do?uri=sys_dictionary.do?sys_id=28333204db93230095a657935e9619b8%26sysparm_view=advanced
The current value set is:
'reference_types=sys_user'
This allows reference fields to be selected which point to the sys_user table. As the Contact field is a reference to the Contact table, we will have to update this attribute:
'reference_types=sys_user;customer_contact'
This will then allow the fields pointing to the Contact table to be clickable.
Related Links
Docs: Dictionary attributes