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Deferred State is not visible on the Demand form - Support and Troubleshooting
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  • Deferred State is not visible on the Demand form
KB0756560

Deferred State is not visible on the Demand form


853 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

No indication of a Demand being Deferred on the form. The bar on the top of the form will not show the Deferred state.

Release

All Releases

Cause

Customized "Defer" UI Action and Dictionary Choice value for "state" without the value of 10.

Resolution

Normally, when a Demand is put into the Deferred state, the "Completed" state on the top bar is replaced with "Deferred".
If this is not happening on your instance you may have customized the UI Action "Defer" on the dmn_demand table.
Additionally, you will need to ensure that the state value for Deferred has the value of 10.

To do so, follow the steps below.

1. Navigate to System Definition > UI Actions
2. In the Name column, search for "Defer" and go to the record for the dmn_demand table
3. In the Versions related list, open the latest record with the source of "System Upgrades: glide-RELEASENAME..."
4. In the related links section, click "Revert to this version"
5. Select OK when prompted
6. Now we can check the Dictionary Entry by navigating to System Definition > Dictionary
7. Search for and open the record for the Table of "task" and the Column Name of "state"
8. In the Choices related list, search for the record with the Label of "Deferred" and go to the record
9. Update the Value field to 10 if it is not that already
10. Save the form

After this is finished, everything should look/work as desired.


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