Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Linked Server Conneciton Error via ODBC: "[SN][ODBC ServiceNow Driver][OpenAccess SDK SQL Engine]Base table: XXXX not found.[10129]" - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Linked Server Conneciton Error via ODBC: "[SN][ODBC ServiceNow Driver][OpenAccess SDK SQL Engine]Base table: XXXX not found.[10129]"
KB0756446

Linked Server Conneciton Error via ODBC: "[SN][ODBC ServiceNow Driver][OpenAccess SDK SQL Engine]Base table: XXXX not found.[10129]"


2429 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Linked SQL Server definition in SQL Studio cannot connect to ServiceNow instance using ODBC.

  • The error observed in SQL studio was:

    Cannot Initialize the data source object OLE DB provider "MSDASQL" for Linked Server "SERVIENOW". OLEDB provider "MSDASQL" for Linked Server "SERVIENOW" returned message "[SN][ODBC ServiceNow Driver][OpenAccess SDK SQL Engine]Base table:OA_TYPES not found.[10129]". (Microsoft SQL Server Error:7303)



  • ISQL queries against the instance using ODBC work without a problem.

Release

Client uses Microsoft SQL Server Management Studio connected via ServiceNow ODBC driver to the instance database.

Cause

Linked Server is set to run "in-process" with Microsoft SQL Server.

Resolution

Uncheck the allow in-process flag in your linked server options for OLE DB Provider.

Follow step number 7 and 8 from the documentation below for additional details:

Configure SQL Server
https://docs.servicenow.com/csh?topicname=t_ConfiguringSQLServer.html&version=latest

Related Links

The allow in-process flag force to run the ODBC provider in-process (within the same process as SQL Server).
This setting is not recommended because any issues with the provider can affect the SQL Server process, which in turn could result in crashing SQL server.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.