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Incidents auto-close before the expected time - Support and Troubleshooting
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  • Incidents auto-close before the expected time
KB0756441

Incidents auto-close before the expected time


527 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Incident Autoclosure does not honor the configured time after moving to incident to resolved. Incidents are autoclosed days early in some cases.

Cause

The resolved_at value is set incorrectly when the incident state moves to customized value of 3. 3 is the out of box value for closed on the task table and the states do not align between incident and task tables.

The resolved_at value does not get cleared unless we move from Resolved to In Progress.

Resolution

Add a condition to the custom business rule that prevents it from running on the incident table to ensure the resolved_at field is not populated when the incident state moves to 3.


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