Issue
Symptoms
Unable to hide price in catalog request in Service Portal
Release
All releases supporting Service Portal
Cause
By design, prices are displayed in catalog requests in Service Portal
Resolution
1. Navigate to the widget list
2. Search for "Request Fields" widget
3. Clone the widget by clicking the "Clone Widget" button
4. Remove "price" on line 13 of the server script for the cloned "Request Fields" widget:
var fields = $sp.getFields(gr, 'number,state,priority,sys_created_on,price');
5. Click Update
6. Navigate to Service Portal Edit Page:
<your instance>/sp_config?id=page_edit&p=sc_request&table=sp_instance&sys_id=cc316d33d7230200a9addd173e24d4f5
7. Remove "Request Fields" widget from the page
8. Add the cloned "Request fields" widget to the page
9. Click Save