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A customer administrator cannot assign roles in system properties on Service Portal. - Support and Troubleshooting
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  • A customer administrator cannot assign roles in system properties on Service Portal.
KB0755923

A customer administrator cannot assign roles in system properties on Service Portal.


1544 Views Last updated : Jun 16, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

A customer administrator (sn_customerservice.customer_admin role) cannot assign roles listed in the system properties (sn_customerservice.contact_role_assignment) on Service Portal.

Steps to reproduce:

  1. Go to Customer Service > Administration > Properties (sn_customerservice.contact_role_assignment system property)
  2. The list of roles in External roles that can be assigned to contacts via Customer portal should be available to edit on CSM.
  3. Impersonate a user who has the customer admin (sn_customerservice.customer_admin) role.
  4. Go to /csm
  5. Go to Support > Contacts
  6. Select any contact to edit.
  7. Select Edit Role.

Following these steps, only sn_customerservice.customer and sn_customerservice.customer_admin are available. The admin cannot see the Partner administrator role (sn_customerservice.partner_admin) or the Partner role (sn_customerservice.partner).

Release

Any version

Cause

The roles availability depends on the configuration of the account that the contact belongs to.

If the account is configured only as a customer then partner roles would not be available in Edit Role.

Resolution

To check if the account is a customer or Partner, follow these steps:

  1. Go to Customer service > Contact
  2. Open the contact (user) to check the account this contact belongs to.
  3. Go to Customer > Account
  4. Open the account to see which checkbox is selected: Customer or Partner

 

 

 


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