Issue
A customer administrator (sn_customerservice.customer_admin role) cannot assign roles listed in the system properties (sn_customerservice.contact_role_assignment) on Service Portal.
Steps to reproduce:
- Go to Customer Service > Administration > Properties (sn_customerservice.contact_role_assignment system property)
- The list of roles in External roles that can be assigned to contacts via Customer portal should be available to edit on CSM.
- Impersonate a user who has the customer admin (sn_customerservice.customer_admin) role.
- Go to /csm
- Go to Support > Contacts
- Select any contact to edit.
- Select Edit Role.
Following these steps, only sn_customerservice.customer and sn_customerservice.customer_admin are available. The admin cannot see the Partner administrator role (sn_customerservice.partner_admin) or the Partner role (sn_customerservice.partner).
Release
Any version
Cause
The roles availability depends on the configuration of the account that the contact belongs to.
If the account is configured only as a customer then partner roles would not be available in Edit Role.
Resolution
To check if the account is a customer or Partner, follow these steps:
- Go to Customer service > Contact
- Open the contact (user) to check the account this contact belongs to.
- Go to Customer > Account
- Open the account to see which checkbox is selected: Customer or Partner