Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Selecting Date and Time button, calendar appears at top left of screen instead of next to field - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Selecting Date and Time button, calendar appears at top left of screen instead of next to field
KB0755803

Selecting Date and Time button, calendar appears at top left of screen instead of next to field


672 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

When the user clicks on a date field button to pop up the calendar, the user sees the calendar in the top left corner of the form:

Release

Confirmed in Madrid, but can also happen in Kingston and London

Cause

In the console will find the following error:

incident.do:2644 RangeError: Invalid language tag: en.us
at Date.toLocaleDateString (<anonymous>)
at e._showMonth (GwtDateTimePicker.js:288)
at e._createControls (GwtDateTimePicker.js:93)
at e.initialize (GwtDateTimePicker.js:37)
at new e (js_includes_doctype.jsx:3)
at Array.<anonymous> (incident.do:2642)
at x (js_includes_ui16_form.jsx:11103)
at wait (js_includes_ui16_form.jsx:11103)
at Object.runQueue (js_includes_ui16_form.jsx:11103)
at Object.getScripts (js_includes_doctype.jsx:243)

The code is expecting "en" instead of "en.us"

Resolution

In the filter navigator go to sys_properties.list.  Search for glide.sys.language.  Check the value that is set.  If the value is "en.US", change it back to "en" which should resolve the issue.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.