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Business Services Status widget in Service Portal is not showing all services - Support and Troubleshooting
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  • Business Services Status widget in Service Portal is not showing all services
KB0755672

Business Services Status widget in Service Portal is not showing all services


1736 Views Last updated : Jun 11, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

When viewing the services_status page in Service Portal, not all the Business Services are showing.

 

Release

Any supported release

Cause

There are two possible causes:

  1. Number of records in cmdb_ci_service table is more than 250
  2. Class is not cmdb_ci_service  

 

Resolution

Resolve either of these causes as follows.

Number of records in cmdb_ci_service table is more than 250

The code in the server script of the Business Services Status widget checks if there is a limit to the number of the records to show in Widget Instance options. If not, this defaults to 250.

If there are more than 250 records in the cmdb_ci_service table, these additional records are not shown.

Edit the widget instance option to show the required number of records.

 

Class is not cmdb_ci_service

When running the Glide Record query on the cmdb_ci_service table, a query restriction checks if the records are of class cmdb_ci_service (line 19 of Business Services Status widget)

                      svs.addQuery("sys_class_name", "cmdb_ci_service"); 


Because of this, if there are any records in cmdb_ci_service table that are not of class Business Service, those records are not shown.

If the requirement is to show all records, clone the Business services widget, and comment out the above line of code and use this cloned widget. 


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