Issue
Self-hosted customers setting up Team Development may get the following error: "Unable to validate connection: Loopback and site-local URLs are not supported. Provide the URL of another instance".
Steps to reproduce
- Navigate to Team Development > Remote Instances.
- Click New.
- Enter the information for the user login credentials and hostname for a remote instance.
- Click Test Connection
- The error message is displayed
Release
Please refer to the Resolution section.
Cause
The "glide.update_set.remote.check_host" property is defaulted to "true" in the instances.
Resolution
Log in to the instances and check for name "glide.update_set.remote.check_host" in system properties. If you do not find it, try to create the system property record from UI with following values:
Name : glide.update_set.remote.check_host
type : True/False
value : false
Should this fail, you will need to update or create this property in the database, with the following SQL:
SELECT * FROM sys_properties WHERE name='glide.update_set.remote.check_host';
If the property exists but has the 'value' column set to "true", run the following:
UPDATE sys_properties set value='false' WHERE name='glide.update_set.remote.check_host';
If the property doesn't exist (as is the case in my instance), create it in the database like so:
- first generate from instance Background scripts a new sys_id:
gs.print(new GlideGuid.generate(null));
- copy the sys_id into the INSERT statement (make sure you replace the sys_id in red with the value you got generated):
INSERT INTO sys_properties (name, suffix, type, description, choices, is_private, ignore_cache, value, sys_id, read_roles, write_roles) VALUES ('glide.update_set.remote.check_host', 'glide.update_set.remote.check_host', 'boolean', NULL, NULL, 0, 0, 'false', 'df34bce3db4fc4d0cdec8324399619fd', NULL, NULL);
INSERT INTO sys_metadata (sys_class_name, sys_name, sys_update_name, sys_id, sys_updated_by, sys_updated_on, sys_created_by, sys_created_on, sys_mod_count, sys_scope, sys_package, sys_policy) VALUES ('sys_properties', 'glide.update_set.remote.check_host', 'sys_properties_df34bce3db4fc4d0cdec8324399619fd', 'df34bce3db4fc4d0cdec8324399619fd', 'sergiu.panaite@snc', '2020-02-12 13:17:20', 'sergiu.panaite@snc', '2020-02-12 13:17:20', 0, 'global', 'global', NULL);
After doing either of the above, log back into the instance, and clear the cache of the properties by running the following script in "Scripts - Background":
GlidePropertiesDB.invalidate();
Finally, restart the instances.
Note: The above SQL commands are meant for MariaDB installations only! Should your company's instances be running on Oracle, you will need to convert the SQL.