Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
"anonymous user error" during kubernetes pattern discovery - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • "anonymous user error" during kubernetes pattern discovery
KB0754946

"anonymous user error" during kubernetes pattern discovery


1165 Views Last updated : Mar 5, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

While running kubernetes discovery the below error can be seen in discovery logs:


User \“system:anonymous\” cannot get v1 at the cluster scope”,“reason”:“Forbidden”,“details”:{“name”:“namespaces”,“kind”:“v1”},“code”:403}

Release

All

Cause

OpenShift kubernetes does not support basic authentication. A Bearer Token is required for Authentication.

https://docs.openshift.com/container-platform/4.10/rest_api/index.html

Resolution

Kubernetes credentials need to be configured with bearer token option:

https://docs.servicenow.com/bundle/sandiego-it-operations-management/page/product/service-mapping/concept/kubernetes-discovery.html

Related Links

If after configuring the credentials and Kubernetes Discovery completes successfully without discovering the Nodes with pattern steps error "Invalid username/password combo", please review this KB: KB0994019


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.