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Invalid Serial Number field populated for HPE Proliant Gen 10 servers - Support and Troubleshooting
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  • Invalid Serial Number field populated for HPE Proliant Gen 10 servers
KB0754390

Invalid Serial Number field populated for HPE Proliant Gen 10 servers


1826 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Invalid Serial Number field populated for HPE Proliant Gen 10 servers. HPE Proliant Gen10 servers return unusual serial numbers for WMI queries returning Hardware Information. 

Release

All currently supported releases.

Environment

When you are using Windows OS - Desktops for discovery

Cause

  • As per the following HP's knowledge article, WBEM provider is not supported - https://support.hpe.com/hpsc/doc/public/display?sp4ts.oid=null&docLocale=en_US&docId=mmr_sf-EN_US000021120
  • We are able to discover most of the data fine on the HPE Proliant Gen 10 server except for a few discrepancies with the serial number being returned from WMI queries. In this case the WMI query for baseboard returned invalid serial number.
  • The pattern lookup information includes all Serial Numbers. The "OSs - Pre Sensor" Pattern Pre/Post script will iterate through the Serial Numbers list and check their validity. The first matching valid Serial Number will be used to overwrite the CI's serial_number field
  • From the 'Windows OS -Server' pattern OOB , step '5.( Insert serial number to cmdb_ci_win_server': Value=$cmdb_serial_number[1].serial_number ) we get the 1st row (baseboard) in the temporary cmdb_serial_number table and set it to the target serial number. 

Resolution

- As a workaround, Add the incorrect serial number to "dscy_invalid_serial" table so that the "OSs - Pre Sensor" Pattern Pre/Post would pick another valid serial number from the list of lookup serial numbers, returned by the pattern, to overwrite the ci.serial_number field with.

 


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