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Description

Symptoms

When a virtual agent topic is accessed in its live version (i.e. from service portal) it throws the message "An unrecoverable error has occurred." The same topic works fine when previewed in the designer.

Release

Madrid

Cause

The affected topic(s) are not (re)published.

Resolution

Topic conversations that are created using the designer are stored in the "sys_cb_topic" table. But their published versions are stored in the "sys_cs_topic" table.

Preview in the designer works fine because that is the 'current' version that is being used. However, when the virtual agent live version is used it's not using the most updated version which explains why it errors out because the topic development is not 'complete' yet at this time.

Resolution would be to publish the topic by clicking on the "Publish" button in the designer or if it has been published re-publish it again.

Additional Information

If the above resolution did not resolve the issue please check if the following knowledge articles apply:

 

Article Information

Last Updated:2019-08-02 20:36:58
Published:2019-07-19