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Virtual Agent topics throw the error "An unrecoverable error has occurred" when used in live version but work fine when previewed in the designer - Support and Troubleshooting
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  • Virtual Agent topics throw the error "An unrecoverable error has occurred" when used in live version but work fine when previewed in the designer
KB0754374

Virtual Agent topics throw the error "An unrecoverable error has occurred" when used in live version but work fine when previewed in the designer


852 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

When a virtual agent topic is accessed in its live version (i.e. from service portal) it throws the message "An unrecoverable error has occurred." The same topic works fine when previewed in the designer.

Release

Madrid

Cause

The affected topic(s) are not (re)published.

Resolution

Topic conversations that are created using the designer are stored in the "sys_cb_topic" table. But their published versions are stored in the "sys_cs_topic" table.

Preview in the designer works fine because that is the 'current' version that is being used. However, when the virtual agent live version is used it's not using the most updated version which explains why it errors out because the topic development is not 'complete' yet at this time.

Resolution would be to publish the topic by clicking on the "Publish" button in the designer or if it has been published re-publish it again.

Additional Information

If the above resolution did not resolve the issue please check if the following knowledge articles apply:

Virtual agent Topics, "Open IT ticket" and "Check IT status" errors out
 
Virtual Agent Service Portal widget default Topic instance option not working and causing errors

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