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Description

Symptoms


Knowledge > Create New leads to a blank/empty screen

Cause


Incorrect attribute format.

Resolution


This is seen due to incorrect attribute value added to 'text' field (Article body) on Knowledge table. Please see the 'Attributes' column on the text dictionary entry: 

<Instance name>/nav_to.do?uri=sys_dictionary.do?sys_id=b502e231dba01300673d4980399619c0%26sysparm_view=advanced

Current value: 
serializer=com.glide.script.TranslatedTextXMLSerializer.html_sanitizer=false,edge_encryption_enabled=true 

Please note, there is a period character being used to separate 'Translated serializer' and 'HTML sanitizer'. The separator should be a comma (,) character as opposed to a period. 

Updated value: 
serializer=com.glide.script.TranslatedTextXMLSerializer,html_sanitizer=false,edge_encryption_enabled=true 

 

Additional Information


Enable sanitization on individual fields

https://docs.servicenow.com/bundle/madrid-platform-administration/page/administer/security/task/t_EnSanitizIndFlds.html

Article Information

Last Updated:2019-08-02 20:37:13
Published:2019-07-16