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Creating a new knowledge article leads to a blank screen. - Support and Troubleshooting
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  • Creating a new knowledge article leads to a blank screen.
KB0754162

Creating a new knowledge article leads to a blank screen.


1340 Views Last updated : Aug 24, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Knowledge > Create New leads to a blank/empty screen

Cause


Incorrect attribute format.

Resolution


This is seen due to incorrect attribute value added to 'text' field (Article body) on Knowledge table. Please see the 'Attributes' column on the text dictionary entry: 

<Instance name>/nav_to.do?uri=sys_dictionary.do?sys_id=b502e231dba01300673d4980399619c0%26sysparm_view=advanced

Current value: 
serializer=com.glide.script.TranslatedTextXMLSerializer.html_sanitizer=false,edge_encryption_enabled=true 

Please note, there is a period character being used to separate 'Translated serializer' and 'HTML sanitizer'. The separator should be a comma (,) character as opposed to a period. 

Updated value: 
serializer=com.glide.script.TranslatedTextXMLSerializer,html_sanitizer=false,edge_encryption_enabled=true 


Additional Information


Enable sanitization on individual fields

https://docs.servicenow.com/csh?topicname=t_EnSanitizIndFlds.html&version=latest


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