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GRC description and policy text fields not copying over to Knowledge Base article - Support and Troubleshooting
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  • GRC description and policy text fields not copying over to Knowledge Base article
KB0753591

GRC description and policy text fields not copying over to Knowledge Base article


651 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

The issue is caused by using single quotes in article body. Please find the sample text statement:

 

To ensure information security events and weaknesses associated with information systems are communicated in a manner allowing timely corrective action to be taken, all employees, contractors and third-party users should be made aware of the procedures for reporting the different types of events and weaknesses that might have an impact on the security of organizational assets.


Information Security is responsible for monitoring the incident response program and offering suggestions for enhancements when necessary.

Incident Response Plan

A documented Incident Response Plan and procedures shall be in place to report security incidents or system malfunctions to management.

Reporting Information Security Events and Weaknesses

All Denny’s personnel and related third parties are required to note and report any observed or suspected security issues, potential incidents, or weaknesses in systems or services to Information Security.

User Responsibility Discovering Weaknesses

Denny’s personnel should not attempt to prove suspected security weaknesses. Testing weaknesses, with the exception of items approved by IT Management, might be interpreted as a potential misuse of the system and could also cause damage to the information system or services.

Scenario:

  1. Navigate to any published policy 

    2. Once it is published, it should create a kb article, with the content, however, it is creating the article but the article body is empty. 

Cause

It is the single quote (Denny's) in the policy text that is causing the problem. The property glide.html.sanitize_all_fields property is missing in the instance.

Resolution

Once the glide.html.sanitize_all_fields property is created with value "true" the issue is solved.

Related Links

Available system properties London 

 

Also additionally, If you have the glide.html.sanitize_all_fields property set to true, then create a policy with policy text having a single table cell, then view xml, you can see the policy_text field has this data,

"<![CDATA[
<table style="border-collapse: collapse; width: 100%;" border="1"><tbody><tr><td style="width: 100%;"> </td></tr></tbody></table>
]]>"

now if you set this property to false, create a policy with policy text having a single table cell, when you view xml, you see this,

"<![CDATA[
<table style="border-collapse: collapse; width: 100%;" border="1"> <tbody> <tr> <td style="width: 100%;">&nbsp;</td> </tr> </tbody> </table>
]]>"

It looks like with glide.html.sanitize_all_fields set to false, the policy text field has an extra "&nbsp;", which cause error when we call the GlideJellyRunner script.

I noticed that there's another property glide.translated_html.sanitize_all_fields, properly for translated html fields.


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