Issue
Symptoms
Microsoft Office 365 Cloud License Management has been set up as documented: Set up Microsoft Office 365 Cloud License Management
but throws an error in the system logs when running the "SAM - Import User Subscriptions" job:
SAM:SampO365Admin: Unhandled exception for profile : 011d2db01b867b00ee510d43cd4bcb41 : Error: {
"error": {
"code": "Authorization_IdentityNotFound",
"message": "The identity of the calling application could not be established.",
"innerError": {
"request-id": "42f6011f-a096-4446-b819-b56e5fd7040a",
"date": "2019-06-19T19:58:39"
}
}
}: no thrown error
Release
Madrid
Cause
Microsoft no longer supports procedure 1 described in the documentation.
Resolution
Follow procedure 2 from the mentioned documentation page Set up Microsoft Office 365 Cloud License Management
To register an application for Office 365 in the Microsoft Azure portal, navigate to Microsoft Azure App registrations (Preview).