Issue
Symptoms
When "Retire" UI action on a KB article is clicked, the article stays published and info message of "article has been published" pops up
Release
All releases
Cause
The "Retire workflow" of the Knowledge Base of the article has been set to "Knowledge - Instant Publish" instead of "Knowledge - Instant Retire"
Resolution
Update the "Retire workflow" of the Knowledge Base of the article to "Knowledge - Instant Retire"