Issue
These steps help to address the issue when you cannot see requests in the My Requests widget in Service Portal.
Release
Madrid release and newer
Cause
Under Catalog Administration, there are missing entries in application module My Request Filter.
The My Requests widget (with ID my-requests-v2) functions based on the filter conditions and display settings configured in the My Request Filter application module.
Resolution
To resolve this:
- On a working instance, under Catalog Administration, go to the application module My Request Filter.
- Right click All, and then select Open new window.
- Right click the context menu, select Export, and then select XML.
- Import the XML file to the instance in question.
Related Links
For more details on request filters, see the product documentation, Define filters for My Requests