Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
PA dashboard tab content does not change when clicking on different tabs - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • PA dashboard tab content does not change when clicking on different tabs
KB0752512

PA dashboard tab content does not change when clicking on different tabs


881 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

From the customer perspective, this issue is presented on Responsive Dashboards that contains more than one tab, and the content of these tabs have one or more reports. Clicking on a few of the tabs does not work, and the content of the dashboard remains the same. This is not the same as having several tabs with the same content because the content itself does not refresh when the user clicks on the tab.

From the technical support perspective, when we click on the tabs that don't render content on the dashboard, what we see by using the console log from the browser's dev tools is malformed JSON.

js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:124 SyntaxError: Unexpected token 	 in JSON at position 1105
    at JSON.parse ()
    at Cc (js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:21)
    at gc (js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:98)
    at js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:99
    at q (js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:12)
    at md (js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:99)
    at f (js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:101)
    at js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:137
    at m.$eval (js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:152)
    at m.$digest (js_includes_dashboards_2.jsx?v=05-06-2019_1040&lp=Mon_Mar_04_08_08_59_PST_2019&c=17_244:149)

 

 

Release

All Releases.

Cause

The cause for this issue is that on the [pa_widgets] or [sys_report] tables, there are one or more records with "name" or "description" or "title" containing a special character. Also using copy and paste to populate the description filed can also copy special characters, thus causing the issue. it is preferable to manually type the entries. 

 

Resolution

Look at each of the widgets that are on your Responsive Dashboard, and check the name, title and descriptions fo the widgets. If you identify any non-ASCII delete and retype the text.

If you are still experiencing an issue, please open a case, and work with your Technical Support Analyst to provide you with a list of records that contain non-ASCII characters. You will then need to go through the list and remove and retype the text.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.