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Multiple Knowledge Base not displaying categories in Service Portal - Support and Troubleshooting
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  • Multiple Knowledge Base not displaying categories in Service Portal
KB0752503

Multiple Knowledge Base not displaying categories in Service Portal


1695 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Knowledge Base are not showing categories in Service Portal

Empty knowledge categories list

 

Cause

The root cause of the issue is the customised version of the widget "KB Categories - KBv3"

Resolution

Revert the custom widget to the out-of-box (OOB) widget

  1. Go to the portal page where the categories are missing.
  2. Click Ctrl + Right-click on the widget and it will give you a list of options
  3. Choose Instance in Page Editor and check the Widget if it is a customised version of the widget
  4. Modify the UI page to use the out-of-box (OOB) widget "KB Categories - KBv3" by choosing in the widget dropdown and Save
  5. If you have not added a custom version and have modified the out-of-box (OOB) version, you need to go to the platform or advanced view.
  6. In the navigation bar, type in sp_widget.list to go to the list of Service Portal widget records.
  7. Filter in the Name or the sys_id of the widget.
  8. In the Versions related list, click both Custom and Upgrade version
  9. Click on Action on selected tows > Compare > Revert to Selected version which is the OOB version
  10. Save.

 


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