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Description

Symptoms


Checkout UI action is missing.

Cause


Previous version of article is not Published or Outdated.

Resolution


The Checkout UI action is not appearing for this record as we are failing part of the condition: 'new KBVersioning().canCheckout(current)'

From the list view on Knowledge table, we can see the previous version of this article is retired. Looking at the function 'canCheckout' found in script include 'KBVersioningSNC' there is a conditional statement:
if(this._getCheckedoutRecord(current))
return false;
return true;

This function is checking if the previous version of this article is set to Published or Outdated. If this is not, this conditional statement is failed and the condition found in the UI action is not passed.

Creating a brand new knowledge article is the suggested fix here. If you would like, you can also write a small script to update the previous version to 'outdated'. At this time there is not available OOB functionality to bring an article out of retirement. Instead, you should consider creating a new article and just copy the information over. This is noted in our documentation:

Note: Retired knowledge articles cannot be searched for by external users or customers. To reuse a retired article, create a new article with the same content, which is published once approved.

Additional Information


Retire a knowledge article
https://docs.servicenow.com/bundle/madrid-servicenow-platform/page/product/knowledge-management/concept/c_RetiredKnowledgeArticles.html

Article Information

Last Updated:2019-08-02 20:38:36
Published:2019-06-27