Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Value is different for the same variable on Catalog Task and RITM variable editors. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Value is different for the same variable on Catalog Task and RITM variable editors.
KB0752171

Value is different for the same variable on Catalog Task and RITM variable editors.


1171 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Value is different for the same variable on Catalog Task and RITM variable editors.

Release

Any supported release

Cause

Having same Label for two different variables. 

Resolution

When a Request is submitted for a Catalog Item, all the variables are displayed on the RITM variable editor.(Unless hidden by a Client Script or UI Policies)

But the catalog Task variable editor will only display the variables included in the "Catalog Task" workflow activity.
or the variables must be Global.

If you have two variables (ex: Reference and Single Line text) with the same Label and only one (Single Line Text) variable was added to the Catalog Task workflow activity.
The RITM variable editor display both the variables but the Catalog Task has only one (Single Line Text).

You might be checking the variable (Reference) value against the variable (Single Line Text) which was not included on the Catalog Task.

So, make sure the Label is unique for the variables on the same catalog Item or add the correct variable to the Catalog Task activity based on the 'name'.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.