Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Mid Server Error: Illegal character in scheme name at index 0 in the agent logs - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Mid Server Error: Illegal character in scheme name at index 0 in the agent logs
KB0752107

Mid Server Error: Illegal character in scheme name at index 0 in the agent logs


7121 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

  •  Post-installation of Mid Server, it shows below error in the MID Server agent logs:
[AMBClientProvider] ERROR com.snc.glide.amb.AMBClient - Illegal character in scheme name at index 0: https://<instance-name>.service-now
java.lang.IllegalArgumentException: Illegal character in scheme name at index 0: https://<instance-name>.service-now

Release

  • The issue can occur in any release.

Cause

  • An extra space character in the instance server URL parameter in the mid server config.xml file.

Resolution

  • In order to resolve this issue, follow the below steps.

    • Connect to the Mid Server Host and Navigate to < Mid-Installation Directory>/agent/config.xml file.
    • Open the file and Locate the following parameter:
          <parameter name="url" value=" https://<instance-name>.service-now>
    • Check if there is any extra space added while adding the URL and remove the same.
    • Save the file and restart the Mid Server.

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.