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Connect Action is not working after a record is created in chat, Error in the logs "No live_group_profile found" - Support and Troubleshooting
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  • Connect Action is not working after a record is created in chat, Error in the logs "No live_group_profile found"
KB0751684

Connect Action is not working after a record is created in chat, Error in the logs "No live_group_profile found"


568 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

After creating a record from a support conversation other Connect Actions are not working. 

If you check the logs you see an error related to 'conversation.document.group' being undefined or "No live_group_profile found for undefined"

Release

All

Cause

After creating a record from a chat the document is updated to that type of record. Since all records do not have a group field (OOB only the chat_queue_entry table does) the document.group is undefined. 

Resolution

A better way to get the live_group_profile sys_id for a conversation to use with the Conversation APIs is to just reference it directly from the conversation object.

Instead of:

conversation.document.group

Use:

conversation.sys_id


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