Issue
Symptoms
'OAuth secret is not available' error message is seen when trying to access the instance from the classic mobile app
Release
Applicable to all
Cause
Querying for incorrect 'name' field in the oauth_entity record
Resolution
Ensure that 'name' field on oauth_entity record is pointing to the correct name out of the box. For example, in London release the name is SeviceNow Mobile App. In Madrid, the name is ServiceNow Classic Mobile App.