Issue
An email sent from an instance to a mailbox that has an out-of-office autoreply set up fails to trigger the out-of-office reply message. Consequently, no autoreply email is received. The email client, such as Outlook or Gmail, is not creating the out of office reply message.
Cause
This can be caused by the following terms in outbound email headers:
- Precedence:bulk - Some spam filters flag bulk email as spam
- Auto-submitted:auto-generated - Some email clients treat these as automated emails and do not bother triggering an auto reply email
Resolution
Remove the terms from the email header sent by the instance. When received, this enables email clients, such as Gmail, to create and send the out of office autoreply.
To do this:
- Go to the System Properties (Sys_properties) table.
- Update the property glide.smtp.precedence_bulk and set the value as false
- Update the sys_property glide.email.outbound.header.auto_submitted and ensure it is blank.
Note: If these system properties are not already present, you may create them
Warning: Ensure these actions are tested in sub-production instances before implemented in production environments