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Sync between Major Case and Child Case is not working - Support and Troubleshooting
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  • Sync between Major Case and Child Case is not working
KB0751260

Sync between Major Case and Child Case is not working


1344 Views Last updated : Nov 29, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Sync between Major Case and Child Case is not working.

Cause

  1. Sync child case fields upon parent chng BR drives the sync.
  2. 'Synchronize fields from parent to child cases' system property should be set to "Yes".
  3. 'sn_customerservice.case_fields_to_sync' system property should have the value set as "priority, state, comments, work_notes, close_notes, resolution_code, product"
  4. 'sn_customerservice.case_fields_to_sync' system property contains an invalid field name. It should contain valid field values, not label values.
  5. Dictionary field was customized

Resolution

  1. Check if "Sync child case fields upon parent chng" BR or above mentioned properties have been customized.
  2. Check the property "Synchronize fields from parent to child cases'' if it set to "Yes".
  3. This property is found in Customer Service > Administration > Properties
  4. Check if the field to be copied exist in 'sn_customerservice.case_fields_to_sync'. If not, add the field there
  5. Make sure that all the fields in 'sn_customerservice.case_fields_to_sync' system property are valid and existing. Make sure that there are no labels in there. Otherwise, the business rule 'Sync child case fields upon parent chng' will be terminated
  6. Check if any dictionary field was customized. eg comments field Type change from Journal Input to Journal. Make the configuration setting same as OOB

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