Issue
Sync between Major Case and Child Case is not working.
Cause
- Sync child case fields upon parent chng BR drives the sync.
- 'Synchronize fields from parent to child cases' system property should be set to "Yes".
- 'sn_customerservice.case_fields_to_sync' system property should have the value set as "
priority, state, comments, work_notes, close_notes, resolution_code, product
" - 'sn_customerservice.case_fields_to_sync' system property contains an invalid field name. It should contain valid field values, not label values.
- Dictionary field was customized
Resolution
- Check if "Sync child case fields upon parent chng" BR or above mentioned properties have been customized.
- Check the property "Synchronize fields from parent to child cases'' if it set to "Yes".
- This property is found in Customer Service > Administration > Properties
- Check if the field to be copied exist in 'sn_customerservice.case_fields_to_sync'. If not, add the field there
- Make sure that all the fields in 'sn_customerservice.case_fields_to_sync' system property are valid and existing. Make sure that there are no labels in there. Otherwise, the business rule 'Sync child case fields upon parent chng' will be terminated
- Check if any dictionary field was customized. eg comments field Type change from Journal Input to Journal. Make the configuration setting same as OOB