Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Orchestration Activity fails with error Access denied when running powershell scripts - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Orchestration Activity fails with error Access denied when running powershell scripts
KB0750852

Orchestration Activity fails with error Access denied when running powershell scripts


2200 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Powershell activity fails without trying any credentials from credentials table with Access denied

06/03/19 14:09:02 (596) ECCSender.1 Sending ecc_queue.550ae779dbf5f300cb5671968c961979.xml
06/03/19 14:09:12 (081) Worker-Standard:PowershellProbe-330a6b79dbf5f300cb5671968c9619f8 Worker starting: Powershell source: 10.27.247.48
06/03/19 14:09:12 (097) Worker-Standard:PowershellProbe-330a6b79dbf5f300cb5671968c9619f8 SEVERE *** ERROR *** Failed while executing script11891173026142638.PS1 (Access denied)
06/03/19 14:09:12 (097) Worker-Standard:PowershellProbe-330a6b79dbf5f300cb5671968c9619f8 Enqueuing: D:\servicenow_midserver\agent\work\monitors\ECCSender\output_2\ecc_queue.330a6b79dbf5f300cb5671968c9619f8.xml
06/03/19 14:09:12 (097) Worker-Standard:PowershellProbe-330a6b79dbf5f300cb5671968c9619f8 Worker completed: Powershell source: 10.27.247.48 time: 0:00:00.016

Release

All releases

Cause

  1. This happens if you have defined a credential tag in the activity and there is no credential with the tag in the credentials table.
  2. If a credential tag is defined in the activity, we always query for the tag and will ignore all the credentials even when you have a valid credentials.

Resolution

-Make sure that the tag defined in the orchestration activity is present in credentials table.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.