Notifications

82 views

Description

Description

For Password reset, the page is redirecting to an SP (Service Portal) and it is constantly looping or refreshing. 

Cause

While in the affected SP use either the inspect network or Chrome Developer tools to see the specific issue it is throwing.

Also, to take a deeper dive, you can do go look into the system logs and look for the following output.

In the logs, we are seeing an infinite loop, from /$sp.do to /login_cpw.do 

2019-06-06 13:48:48 (087) http-27 New transaction 28DAAB3ADB3D77043BCC98B9DB96197D #11543473 /$sp.do 
2019-06-06 13:48:48 (093) Default-thread-13 28DAAB3ADB3D77043BCC98B9DB96197D txid=935b2bbadb3d #11543473 /$sp.do Parameters -------------------------
2019-06-06 13:48:48 (093) Default-thread-13 28DAAB3ADB3D77043BCC98B9DB96197D txid=935b2bbadb3d *** End #11543473 /$sp.do, user: [user_id_removed], total time: 0:00:00.000, processing time: 0:00:00.00-1, total wait: 0:00:00.001, semaphore wait: 0:00:00.001, SQL time: 0:00:00.000 (count: 2), source: 68.87.52.171
2019-06-06 13:48:48 (188) http-43 New transaction 28DAAB3ADB3D77043BCC98B9DB96197D #11543474 /login_cpw.do
2019-06-06 13:48:48 (193) Default-thread-1 28DAAB3ADB3D77043BCC98B9DB96197D txid=975ba37adb3d #11543474 /login_cpw.do Parameters -------------------------
2019-06-06 13:48:48 (193) Default-thread-1 28DAAB3ADB3D77043BCC98B9DB96197D txid=975ba37adb3d *** Start #11543474 /login_cpw.do, user: [user_id_removed]
2019-06-06 13:48:48 (202) Default-thread-1 28DAAB3ADB3D77043BCC98B9DB96197D txid=975ba37adb3d [0:00:00.008] getRealForm
2019-06-06 13:48:48 (208) Default-thread-1 28DAAB3ADB3D77043BCC98B9DB96197D txid=975ba37adb3d *** End #11543474 /login_cpw.do, user: [user_id_removed], total time: 0:00:00.020, processing time: 0:00:00.020, SQL time: 0:00:00.002 (count: 2), ACL time: 0:00:00.001, source: 68.87.52.171 null
2019-06-06 13:48:48 (403) http-28 New transaction 28DAAB3ADB3D77043BCC98B9DB96197D #11543475 /api/now/ui/date_time/legacy

In a couple of events, I have seen some global UI Scripts that has some logic to redirect a page to another SP.

Workaround

Deactivate the UI script and use the steps in the following document "Single sign-on, logins, and URL redirects”. Also, before proceeding verify the Integration - Multiple Provider Single Sign-On Installer plugin (com.snc.integration.sso.multi.installer) is active.

Follow the steps in the following doc:

Single sign-on, logins, and URL redirects

Article Information

Last Updated:2019-08-02 20:40:26
Published:2019-06-17