Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Fields are still editable on the Change request created from Standard Change Template, even after including those in "readonly_fields" of the Standard Change properties. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Fields are still editable on the Change request created from Standard Change Template, even after including those in "readonly_fields" of the Standard Change properties.
KB0750605

Fields are still editable on the Change request created from Standard Change Template, even after including those in "readonly_fields" of the Standard Change properties.


2315 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Fields are still editable on the Change Request created from Standard Change Template, even after including those in "readonly_fields" of the Standard Change properties.

Release

Any supported release

Cause

Client script "Mark standard change fields readonly" has been modified.

Resolution

We have a Client Script in the OOTB named "Mark standard change fields readonly" which make the fields Read-only on the Change Request created from Standard Change Template.
This is an onLoad client script defined on the "change_request" table.
The client script checks for the values entered into the "Read-only fields" field in the Standard Change Properties page.
Change>Administration>Standard Change Properties
If this client script has been modified or the script which verifies the system property has been altered, the fields won't be set to read-only.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.