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6 views

Symptoms

User tries to configure a list layout to add/remove fields and the changes are not saved

Cause

Multiple/Corrupted list records for the affected table in the sys_ui_list for the same view

https://instancename.service-now.com/sys_ui_list_list.do?sysparm_query=name%3Dtablename%5Eview.titleSTARTSWITHDefault%5Eview%3DDefault%20view%5Esys_user%3DNULL&sysparm_first_row=1&sysparm_view=&sysparm_choice_query_raw=&sysparm_list_header_search=true

Resolution

The sys_ui_list table contains records for personalized lists for each user for specific table list view as well as the common system level record for the table list view. if the User field is empty in the sys_ui_list table, it means that this is the layout which will be loaded for all users.

To resolve the issue, make sure that "Affected table has a single record with the criteria: parent is null and user is null" for the specific view in the sys_ui_list

Article Information

Last Updated:2019-06-11 09:22:43
Published:2019-06-11