Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Workflow Not Progressing After Closing Task in Task Activity - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Workflow Not Progressing After Closing Task in Task Activity
KB0750005

Workflow Not Progressing After Closing Task in Task Activity


1485 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

The "catalog task" workflow activity does not finish execution even after the catalog task generated from the activity is closed.

 

 

Release

Madrid

Cause

"TaskStateUtil" script include is customized.

From Madrid, A new function (canRunParentWF) is added to "TaskStateUtil" script include, The closing of the task depends on the business rules "SNC - Run parent workflows", this business rule has a condition "new TaskStateUtil().canRunParentWF(current)" 

canRunParentWF : function(current) {
return (current.state.changesTo(3) || current.state.changesTo(4) || current.state.changesTo(7) || current.operation() == 'delete' || (pm.isActive('com.snc.best_practice.problem.madrid.state_model') && current.getRecordClassName() == 'problem' && current.state.changesTo(ProblemState.STATES.CLOSED)));
}

 

This method is missing on customized "TaskStateUtil" script include

Resolution

Revert the script include "TaskStateUtil" to out of the box or include the above function on the customized script include "TaskStateUtil".


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.