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Description

Symptoms

Newly created record does not show (is not visible) in list view but shows (is visible) after the first update

Release

All

Cause

We are going to take the incident records as an example but this can be applied to any records if the same conditions are met:

  1. Navigate to the Incident->Create New
  2. Create a new incident and click "Submit"
  3. Navigate to Incident->Open (ensure all records are displayed on one page only)
  4. Notice that the newly created incident does not show
  5. Notice that the list view filter contains "active=true^..."
  6. Navigate to the dictionary entry "Active" of an incident record and notice that the default value is set to false

This is why the newly created incident is not showing until it gets updated, then the Active value will be set to true and the record will show in the list view (This can also be checked in the audit history with old and new value for the field "Active").

Resolution

  • Remove the Active=true from the list filter¬†
  • Ensure that the default value of the dictionary entry "Active" on the Task table is set to true (All lower case, when opening the record, click on the tab "Default Value")

 

Article Information

Last Updated:2020-01-28 09:09:29
Published:2020-01-28