Issue
Updates to Knowledge Article are not seen by other users
User can only see his updates
Knowledge not updated
Cannot see article updates
Cause
The user language is invalid. The language was set to 'NUL' which is invalid
The 'Text' field on kb_knowledge is a Translated HTML field, which means that there are different translations for this field, depending on the language of the editor or reader.
Since 'NUL' is not a valid option for the sys_user.language, the other users were unable to read the corresponding translated KB article
Resolution
Set the language of the user to a valid value
Also, update the language of the records in the table [sys_translated_text] which contains the invalid language.