Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Users are able to select non operational Configuration Items(CIs) while creating task records - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Users are able to select non operational Configuration Items(CIs) while creating task records
KB0749158

Users are able to select non operational Configuration Items(CIs) while creating task records


457 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Users are able to select non operational Configuration Items(CIs) at times while creating task records. But while trying to select the using the reference popup, these will not be shown. There are server side scripts in place to hide these from selection.

Release

All available releases.

Cause

The templates these users have might be setting these values. If you check the node logs when these task records are created, you will see that they are using the sys_templates which has non-operational CIs selected for the Configuration Items field. The log will look something like the following.

2019-05-07 12:22:55 (911) Default-thread-7SESSION_ID txid=TRANSACTION_ID #11700576 /xmlhttp.do Parameters ------------------------- 
sysparm_scope=global 
sysparm_processor=AjaxClientHelper 
sysparm_sys_id= SYS_ID_OF_THE_TEMPLATE
sysparm_want_session_messages=true 
sysparm_name=getValues 

Resolution

Remove the non-operational CI from the sys_template record and that will resolve the issue.

Additional Information

https://docs.servicenow.com/csh?topicname=c_IncidentManagement.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.