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Symptoms

Users are able to select non operational Configuration Items(CIs) at times while creating task records. But while trying to select the using the reference popup, these will not be shown. There are server side scripts in place to hide these from selection.

Release

All available releases.

Cause

The templates these users have might be setting these values. If you check the node logs when these task records are created, you will see that they are using the sys_templates which has non-operational CIs selected for the Configuration Items field. The log will look something like the following.

2019-05-07 12:22:55 (911) Default-thread-7SESSION_ID txid=TRANSACTION_ID #11700576 /xmlhttp.do Parameters ------------------------- 
sysparm_scope=global 
sysparm_processor=AjaxClientHelper 
sysparm_sys_id= SYS_ID_OF_THE_TEMPLATE
sysparm_want_session_messages=true 
sysparm_name=getValues 

Resolution

Remove the non-operational CI from the sys_template record and that will resolve the issue.

Additional Information

https://docs.servicenow.com/bundle/helsinki-it-service-management/page/product/incident-management/concept/c_AttachConfigItemsToIncident.html

Article Information

Last Updated:2019-05-21 11:58:53
Published:2019-05-17