Issue
Symptoms
Virtual Agent Topics are working as expected during while previewing but in Service Portal it does not work for end users.
Release
All available releases
Cause
Virtual agent topics were not published after making changes to the same. Whenever you make changes to the virtual agent topic and saves it, it will be visible when you preview it. But for an end user to see these changes, you have to publish the topic again.
Resolution
Publishing the topic again will resolve the issue.
Additional Information
https://docs.servicenow.com/csh?topicname=virtual-agent-overview.html&version=latest
https://docs.servicenow.com/csh?topicname=itsm-virtual-agent-topics.html&version=latest